Error after installation of strawberry when trying to login

Post your problems with the script.

Error after installation of strawberry when trying to login

Postby jfade » Mon Jul 31, 2006 7:56 pm

Hi! :) First off, thanks for such a great script, I've been using CuteNews.RU for a long time now and I love it. :D



Here's my problem, after installing (which worked well) I try to login with the username and password I specified, and it comes up with this at the top:



Warning: Invalid argument supplied for foreach() in /(full path here)/news/inc/functions.inc.php on line 94



Any ideas what it means? I know that mySQL DB, user, and such are all correct, so I'm not sure what the problem is...



Thanks in advance! :)
jfade
 
Posts: 3
Joined: Tue Dec 27, 2005 11:49 pm

Postby jfade » Mon Jul 31, 2006 8:44 pm

OK, nevermind, I figured that out. :) I had done something stupid, which is not unusual. :P



New problem:





Code: Select all
<?php

   if ($HTTP_GET_VARS["category"]) {

      $category = $HTTP_GET_VARS["category"];

   } else {

      $category = '3';

   }

   if ($HTTP_GET_VARS["id"]) {

      $id = $HTTP_GET_VARS["id"];

   } else {

      $id = '0';

   }

   if ($category == '3' && $id == '0') {

   $template = "Front";

   } else {

      if ($category == '24' && $id == '0') {

      $template= "Front";

      } else {

      $template = "NewTemp";

      }

   }

   $number = 10;

   include rootpath.'/show_news.php';

}

?>


That doesn't seem to work for me at all anymore, but it did in CuteNews.RU 2.5.4. It display back any news at all. It does include the head.php file at the top of the page, like so:



Code: Select all
<?php

include './news/head.php';

?>




So I'm not sure why it's not working. :( Any ideas? Thanks in advance, again! :D
jfade
 
Posts: 3
Joined: Tue Dec 27, 2005 11:49 pm

Postby Syrion » Fri Aug 04, 2006 9:59 am

What are you trying to achieve with the new problem? (I don't really understand it, since I'm not a PHP-programmer, altough I understand parts of it.)
User avatar
Syrion
 
Posts: 185
Joined: Wed Aug 02, 2006 2:03 pm

Postby dpe » Tue Sep 12, 2006 9:20 pm

Hello,

I get the same error message on login after a new install of Strawberry 1.1.1

Warning: Invalid argument supplied for foreach() in /(full path here)/news/inc/functions.inc.php on line 94




I installed Strawberry without any problem (no error message)



It seems that the user specified during the install hasn’t been created: MySql table ‘cute_users’ is empty

I tried to install Strawberry on another computer, and I had no problem, the user was correctly created in the table



DPE
dpe
 
Posts: 1
Joined: Sun Sep 10, 2006 8:18 pm
Location: Switzerland

Postby FI-DD » Wed Sep 13, 2006 11:24 am

You could try again.



Or you could manually create the user in the table using the data from your working installation.
User avatar
FI-DD
Admin
 
Posts: 2971
Joined: Thu Sep 22, 2005 11:27 am
Location: Germany


Return to Strawberry Support



Who is online

Users browsing this forum: No registered users and 1 guest

cron

x